Jump to content

The Train Doctor

Help! My train is broken!

312 topics in this forum

  1. Lubricants 1 2 3

    • 58 replies
    • 14,957 views
    • 27 replies
    • 693 views
  2. DE10 = DEAD 1 2 3 4

    • 92 replies
    • 10,632 views
  3. Atlas MP15 HELP!! 1 2 3 4 5

    • 117 replies
    • 9,655 views
  4. Kato Point derail - advice ? 1 2

    • 30 replies
    • 7,082 views
  5. Traction Tyres - friend or foe ? 1 2 3 4 5

    • 124 replies
    • 6,189 views
  6. Tomix 209-0 fits and starts, and growling 1 2

    • 44 replies
    • 4,766 views
  7. Weird sound coming from motor Tomix Kiha 40 1 2 3

    • 72 replies
    • 4,612 views
  8. Having some problems on my track. 1 2

    • 30 replies
    • 3,948 views
  9. Tomix 115 Running Jerkily 1 2

    • 33 replies
    • 3,941 views
  10. Saggy Bottom Trolley

    • 16 replies
    • 3,740 views
  11. superglue mistakes

    • 3 replies
    • 3,640 views
  12. The Perplexing Case Of The Melty Lounge Cars 1 2 3

    • 62 replies
    • 3,444 views
  13. Kato EF65 Conundrum 1 2

    • 43 replies
    • 3,170 views
  14. Portram which isn't run

    • 18 replies
    • 3,124 views
  15. Repair points on Kato #4 Turnout?

    • 5 replies
    • 3,120 views
  16. Grumbling 1 2

    • 25 replies
    • 3,080 views
    • 25 replies
    • 3,064 views
  17. KATO N700 Series Shinkansen Bullet Train "Nozomi" 1 2

    • 35 replies
    • 3,021 views
    • 21 replies
    • 2,887 views
  18. MicroAce KiHa 91 - Coupler problems 1 2

    • 26 replies
    • 2,669 views
  19. Noisy E531 - Kato

    • 17 replies
    • 2,639 views
    • 5 replies
    • 2,578 views
    • 21 replies
    • 2,554 views
  20. Kato couplers ??

    • 12 replies
    • 2,444 views
×
×
  • Create New...